Jump to content



Photo

OSx86 sur P7P55D-E


  • Please log in to reply
8 replies to this topic

#1 t1mman

t1mman

    Accro

  • Members
  • PipPipPipPipPip
  • 381 posts

Posted 01 March 2011 - 09:11 AM

J'ai fait un premier test hier pour rouler OSx86 sur mon nouveau kit, je me suis rendu relativement loin (manque certains drivers, mais tout est foncionnel et fluide) donc voici comment faire pour les chipset du genre:
(basé sur ca: http://www.insanelym...howtopic=224303)

Tout d'abord, j'ai utilisé le "iATKOS S3 version 2"

Ensuite, on remet les settings du bios à défault et on change le type de connecteur SATA pour AHCI plutôt que IDE ou Raid.

Enuite, il faut setter le multiplicateur manuellement (j'ai un core i5 760, donc 21x1333 pour le 2.8ghz), donc si vous le connaissez pas par coeur, trouvez le avant! ;)

Bon, ensuite on boot sur le DVD et on rajoute l'option "busratio=21" (remplacez le 21 ici par votre multiplicateur)
On laisse booter le DVD jusqu'au premier menu

Il faut formater le HDD en "MRB/MacOS Extended Journaled"; Perso j'ai mis un HDD en une partition et setté ca le plus basic possible. Pour l'installation initial aussi c'est toujours plus "sage" de débrancher ces autres HDD pour être certain de pas gaffer!

Lorsqu'on retourn au menu de selection de la destination, il faut cliquer sur "customize" pour ajouter certains pilotes et changer le Kernel. Voici les changement à faire / Ajouter:

Kernel: qoopz 10.2.0
j'ai ajouté les drivers suivant:
SATA: Intel, j'ai rien en SATAIII-6Gb ni sur le JMicron, je conseil justement de garder ca sur le Intel pour que ca soit plus facile. mais, au pire, le JMicron semble être dans la liste
Sound: J'ai rien mis parceque j'ai un module USB qui va faloir je test
VGA: Nvidia, dans efi string on met ca config (DVI/VGA pour moi)
Network: Wired, Realtek, j'ai tout coché parceque je sais pas quel est compatible avec le RTL-8112L

Le reste de l'install passe bien, au premier boot faut refaire l'option du "busratio=xx" sinon ca boot pas :S
Je suis rendu à l'etape d'installer les updates et d'ecrire dans le "Extra\com.apple.boot.plist" Kernel Flag "busratio=21" pour pas avoir à le faire tout le temps, mais à date le display est fluide et dans ma résolution (faque la carte video est au moin fonctionnelle) et le network marche.

Si ca vous interesse, je vous tiens au courant!

#2 nka

nka

    Geek God

  • [QiT] Admins
  • PipPipPipPipPipPipPipPipPipPip
  • 13,267 posts
  • LocationQuebec, Canada

Posted 01 March 2011 - 09:15 AM

Woah nice! Merci de partager! :)
::: nka

#3 t1mman

t1mman

    Accro

  • Members
  • PipPipPipPipPip
  • 381 posts

Posted 02 March 2011 - 09:19 AM

Update: Je pense que le 10.6.5 combo fait chier le USB, mon clavier et ma sourris marchent plus apres cet update là... j'investigue le tout! ;)

J'ai essayé aussi avec le kernel qoopz 10.3.0 et ca fait pareil!

#4 t1mman

t1mman

    Accro

  • Members
  • PipPipPipPipPip
  • 381 posts

Posted 03 March 2011 - 08:37 AM

Update 2 (je vais éditer le premier post mis que ca soit fini pour donner la marche détaillé)

J'ai finalement confirmer que le trouble est dû à un update des "driver" USB, ils ont changé avec 10.6.5. Mais Bonne nouvelle, on peut faire un "rollback" des dit fichiers!

Donc hier j'ai repartis le tout; reinstall comme plus haut, j'ai installé le "combo" update 10.6.6 et ensuite, avant de rebooté, j'ai roulé "MultiBeast" (http://tonymacx86.bl...stallation.html) pour faire le rollback des IOUSBFamily et j'ai retrouvé le controle! Yéé!

Donc, j'ai réusis à installé mes pilotes pour mon Line6 UX2 (carte de son USB avec entrée micro+guit) mais j'ai pas encore testé le tout.
Par contre, je semble avoir un trouble avec le "wake-up", j'ai fait un "reset" des droits pis certaines choses avec MultiBeast (qui faudrait faire normalement apres avoir remplacé des "kext", les drivers de OsX) je revérifie le tout ce soir et je vous tiens alerte!

Ce soir si je peut, je bench le tout! :P

#5 nka

nka

    Geek God

  • [QiT] Admins
  • PipPipPipPipPipPipPipPipPipPip
  • 13,267 posts
  • LocationQuebec, Canada

Posted 03 March 2011 - 11:54 AM

Ca me fait penser a mon projet de LB. J'savais que certains me lisais... mais ya rien a "repondre" haha! Continu a partager! :D
::: nka

#6 t1mman

t1mman

    Accro

  • Members
  • PipPipPipPipPip
  • 381 posts

Posted 04 March 2011 - 09:40 AM

Update d'hier:

J'ai ajouté la "patch" pour le wake up (sleepenabler kext) et bien, tout fonctionne!

Donc, Je me suis preté à un exercises interessant: Calcul du "côut de la pomme". J'ai pris un iMac 21.5 avec l'upgrade du core i5 et j'ai monté un PC équivalent chez NCIX:

3.60GHz Intel Core i5 N/A
4GB 1333MHz DDR3 SDRAM - 2x2GB N/A
1TB Serial ATA Drive N/A
ATI Radeon HD 5670 512MB GDDR3 SDRAM N/A
8x double-layer SuperDrive N/A
Apple Wireless Keyboard (English) & User's Guide N/A
Magic Mouse N/A
Prix: 1819

Core i5 680 322,42
Asus P7P55D-E 135
Corsair 2X2GB DDR3-1600 66,21
Antec Tree hundred 49,99
Antec TruePower 650W Modulaire 69,99
WD Caviar Black 1TB Sata3 93,98
Sapphire HD5670 115,17
DVD Samsung SH-S223C 29,98
Logitech Cordless MX 5500 195,97
Samsung BX2240X 21,5 LCD 209,98
Assemblage NCIX 50
Total 1338,48


Coût de la pomme: 480.31$

Donc si on y vas plus intelligent, on coupe 100$ pour mettre un core i5 760, on prend pas la carte la plus cher (enleve quoi, 40$) pis qu'on prend un kit clavier souris "normal", tu coupes un autre 100$; donc encore 240$ de difference!


Prochaine étape: on test le 3D dans les jeux (bon, on peut quasiement dire "LE" jeux, aux nombre de jeux rescent qui à sur cette plateforme) et on install garage band pour jouer de la guit avec mon UX2 (probablement la seule vrai raison de cet exercise, sinon de dire à mon beau père que je l'ai fait pour 500$ de moins :P)

Edited by t1mman, 04 March 2011 - 09:45 AM.


#7 tomz

tomz

    Accro

  • [QiT] Specialiste
  • PipPipPipPipPip
  • 285 posts
  • LocationQuébec

Posted 04 March 2011 - 11:38 AM

Je l'ai fait sur mon Laptop HP 6710b .. j'avais réussi à l'installer et tout mais il ne bootait pas .. il virait en rond :P

Par manque de temps j'ai abandonné le projet et continué à le rouler sur un vmware :P

Edited by tomz, 04 March 2011 - 11:39 AM.


#8 t1mman

t1mman

    Accro

  • Members
  • PipPipPipPipPip
  • 381 posts

Posted 04 March 2011 - 03:04 PM

J'avais aussi essayé avec un P4 et P4P800 mais jamais réussis... principalement à cause du video j'pense... Mais bon, quand on a des nouveaux jouets, faut jouer avec :P

#9 ghous

ghous

    Habitué

  • Members
  • PipPipPipPip
  • 162 posts

Posted 02 October 2017 - 05:19 AM

Tres bien. Merci pour partager.






0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users